Install Techdemo 1 on Mac OS X

From Post-Apocalyptic RPG wiki

Jump to: navigation, search

Download.png This article covers setup instructions!

Setup articles explain how to download and intall a stable or unstable version of PARPG on a specific platform.

This article describes how to download and setup up the stable Techdemo 1 release on Mac OS X systems.

Contents

Supported Mac OS X versions

Fixme.png Please help FIXME: Are the any specific Mac OS X versions that are too old to run FIFE/PARPG on them?

Install process

Option #1: Manual install

  1. Use mac ports and scons
  2. Follow these instructions: http://wiki.fifengine.de/Building:Mac:Scons
  3. Do not use scons ext, just scons to build, use ports to install the libraries (same as linux)
  4. There was some issue with this on 10.6 but I think it has been fixed since

Option #2: Via macports

  1. Run
    sudo port install fife

Notes: (only tested on 10.5.4) The only sticky bit is that it installs ALL the prereqs (including python26) into your ports directory (default /opt/local). It installs FIFE in the standard libraries for THIS installation. That means you have to make sure that the mac ports python 26 is your default python (or ideally, only python - but with mac good luck with that, I think I have 4 pythons) and your sys.path points to the correct place.

Personal tools